Integrating with Visual Studio 2017 Team Explorer

BlackStuff's Avatar

BlackStuff

08 Dec, 2018 09:47 PM

I have a project on AppHarbor that I maintain using the command line version of Git, but I was thinking now that Visual Studio has built in support for Git it would be more convenient to use their tools.

Has anyone successfully managed to port an existing Git repo into Visual Studio? I've tried adding my appharbor repo url to the server list but it just fails with a 404 error.

I've tried creating a new repo in a new folder and cloning the remote Git repo to there and that appears to work, except that when I try to push changes it says that the local branch doesn't track a remote one and every option is disabled.

Any ideas would be hugely appreciated

  1. Support Staff 1 Posted by rune on 09 Dec, 2018 01:19 AM

    rune's Avatar

    Hi,

    I suspect you might be receiving an HTTP 404 due to an authentication failure. You might just have to add your username to the repository URL, but perhaps you can let me know what URL you're adding when it doesn't work in Visual Studio?

    Also, you can likely address the branch tracking when pushing a new local branch with the steps mentioned in this Stack Overflow answer.

    Best,
    Rune

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac