asp.net core 0x80131040 error

350540's Avatar

350540

12 Sep, 2018 11:34 AM

I have an working application, last commit was 9/9/18 3:15 PM. Everything worked fine!
Three days later i see that site isn't working and showing error = 0x80131040
Nothing has changed!! Nothing!!

But i saw that deploy date has changed from 9 oktober to 12 oktober and this looks like server was rebuild with another environment and another .net framework version - and this cause an application crash.

I tried to take up .net framework version (unfortunately: there's no .net framework 2.1.3 onto server), later i roll back my upgrade and restore last success commit (that worked 9/9/2018), but now app show only blank page with 500 Internal server error.

Error was:

FileLoadException: Could not load file or assembly 'Microsoft.EntityFrameworkCore, Version=2.1.3.0, Culture=neutral, PublicKeyToken=adb9793829ddae60'. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

But all my *.csproj contains 2.1.2:

<PackageReference Include="Microsoft.EntityFrameworkCore.Tools" Version="2.1.2" PrivateAssets="all">

(Updating to 2.1.3 works locally, but after building on apphb doesn't work)

What's changed? How can i fix this issue?

  1. Support Staff 1 Posted by rune on 12 Sep, 2018 12:33 PM

    rune's Avatar

    Hi,

    Ugh sorry to hear your application ended up not working without changes on your end. I can confirm that the errors started cropping up shortly after the redeployment last night, and it's likely related to this maintenance since all applications were migrated to newly patched servers running the latest versions of ASP.NET and .NET Core version 2.1.4.

    I can see that the build you pushed shortly after you wrote here seemed to work fine (the most recent build errors out though, so perhaps try and roll back to the working version to confirm it's fixed). Looks like you updated to .NET Core 2.1.4 in the previous, working build, which was also the version the new servers .

    In any case, regular (usually monthly) server maintenance like this shouldn't, and usually doesn't, require action on your part. I'm a bit puzzled about why the error cropped up in the first place. The previous revision of server type hosting your apps had version 2.1.2 installed, but 2.1.3 was never available on those servers when it was working - and I'm not sure why your application suddenly would start to require those versions. We also leave previously installed .NET Core versions (like .NET Core 2.1.2 in this case) installed for compatibility and minimize application failures while people update their applications accordingly.

    Happy to take a closer look at your project if you're ok with that, but also just want to confirm that updating to .NET Core 2.1.4 fixed the issue for you?

    Best,
    Rune

  2. 2 Posted by 350540 on 12 Sep, 2018 01:09 PM

    350540's Avatar

    Rune,

    Thanks for your support.

    Updating from 2.1.2 to 2.1.4 fixed my isssue.

  3. Support Staff 3 Posted by rune on 18 Sep, 2018 03:11 AM

    rune's Avatar

    Hi,

    Forgot to follow up on this -- glad to hear upgrading fixed the issue, and thanks for the heads up and reporting it in the first place!

    Best,
    Rune

  4. rune closed this discussion on 18 Sep, 2018 03:11 AM.

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac