No Luck building F# since VS 2017 Upgrade

rowinginmotion's Avatar

rowinginmotion

02 Jul, 2017 07:33 PM

We've successfully run a mixed C#/F# web app even using some PCLs on AppHarbor for a few years. As I tried to push a recent update however, I've been smashing into issues with out F# projects unable to compile.

I tried several variants, including adjusting my fsproj files to the default F# library templates that VS2017 generates (or so I believe).

With my most recent version of the code that I believe matches the VS2017 library templates, I still get errors like this

"D:\temp\wxon43tj.u0w\input\RowingInMotion.Analytics.Data\RowingInMotion.Analytics.Data.fsproj" (4:2) on node 2 (GetTargetFrameworkProperties target(s)).
     4>D:\temp\wxon43tj.u0w\input\RowingInMotion.Analytics.Data\RowingInMotion.Analytics.Data.fsproj(52,3): error MSB4102: The value "" of the "Project" attribute in element <Import> is invalid. Parameter "path" cannot have zero length.
This is the commit id in question:
31553e86bb30a502ebc8f3cde08e16262c5a4ebc

And here's a build log:
https://appharbor-logs.s3.amazonaws.com/42/27b94a-75ec-4c15-bcae-a0...

  1. Support Staff 1 Posted by rune on 05 Jul, 2017 04:21 AM

    rune's Avatar

    Hi,

    This may well be related to a recent build server update, although it's interesting that this doesn't seem to be a general issue -- another customer did write about a similar issue just yesterday though. I noticed this suggested solution which actually may be desirable in either case - particularly with regards to referencing NuGet package so you can depend entirely on the targets file there rather than the build server setup.

    That said, the build servers have just been updated with the most recent VS 2017 build tools, and also includes the F# 4.1 compiler mentioned in the Stack Overflow answer I linked to above. The updated build tools also includes fixes related to F# project structure, so can you perhaps try and push your application again as this may already work without any modifications to your project(s)?

    Best,
    Rune

  2. 2 Posted by rowinginmotion on 21 Jul, 2017 08:14 AM

    rowinginmotion's Avatar

    Just want to report back, the linked Stackoverflow answer helped me set up the build correctly.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac