Mlab add-on auth failed

karmanov's Avatar

karmanov

09 Jun, 2017 09:23 AM

Hi,
I installed your mlab addon for my appharbor application .
To learn how it works I put this sample project in my app.
this is application I have problem with

Then I get this message:
Command 'authenticate' failed: auth failed (response: { "ok" : 0.0, "errmsg" : "auth failed", "code" : 18 })

Variable "MONGOLAB_URI" is present in application settings, and its seems to used in mlab authentification.

What is wrong with my credentials?

  1. Support Staff 1 Posted by rune on 10 Jun, 2017 12:54 AM

    rune's Avatar

    Hi,

    It seems like the app is configured correctly based on the sample project on GitHub. The database seems to be provisioned and working fine though -- have you tried connecting to it from your own machine using a MongoDB client?

    Also you may want to try and remove and install the add-on again. I couldn't see if the password we have on file is the same as the one currently set on mlab, but perhaps this has changed in the meantime? This could cause the configuration to be out of sync, so reinstalling would eliminate that potential cause (and others) and may be worth trying first as the database doesn't seem to have any data in it right now.

    Best,
    Rune

  2. 2 Posted by karmanov on 13 Jun, 2017 01:19 PM

    karmanov's Avatar

    So, I tried to reinstall add-on, to connect from my computer, to create a separated mlab account. All failed. The problem was that I used old version of mongodb c# driver.
    After upgrading it the app started working correctly.

    Thanks for fast response.

  3. karmanov closed this discussion on 13 Jun, 2017 01:19 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac