AppHarbor's Background Worker runs unintentional EXE files

h3llb0y2012's Avatar

h3llb0y2012

20 Mar, 2017 10:54 PM

So I have shipped a couple of EXE files with my project and marked them to be copied to output upon compilation. the problem is that the Background Worker runs them for some reason and they don't simply exit with code 0 (since they take arguments) and the worker keeps retrying to run them. Is there any solution for this issue?

Thank you in advance!

  1. 1 Posted by h3llb0y2012 on 20 Mar, 2017 11:17 PM

    h3llb0y2012's Avatar

    Never mind, i was impatient. Found a solution here: https://support.appharbor.com/kb/getting-started/background-workers

    Going to give it a shot now!

  2. 2 Posted by h3llb0y2012 on 20 Mar, 2017 11:21 PM

    h3llb0y2012's Avatar

    No. It didn't help since the exe files that I added are not in the source I upload, so I can't edit any .config files for them. Problem not solved!

  3. Support Staff 3 Posted by rune on 22 Mar, 2017 10:22 PM

    rune's Avatar

    Hi,

    Ok so you could actually just add the configuration files matching the name of the executables to configure it using the approach outlined in the KB article. Have you tried that?

    Another solution would be to add a Procfile (currently in public beta) by specifying the executable to run like so:

    urgentworker: exampleworker.exe
    

    And put it in the root directory of the repository. This will instruct the background worker to only run the executables listed in the Procfile, which can also take arguments and have multiple executables per worker, e.g. like so:

    fooworker: exampleworker.exe foo bar
    fooworker: bar.exe qux
    

    Perhaps that'd be more convenient for your use case?

    Best,
    Rune

  4. 4 Posted by h3llb0y2012 on 22 Mar, 2017 10:59 PM

    h3llb0y2012's Avatar

    The Procfile worked correctly, thank!

    I have another issue but this one is closed for now

  5. h3llb0y2012 closed this discussion on 22 Mar, 2017 10:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac