403 - Forbidden: Access is denied.

Ben Parker's Avatar

Ben Parker

16 Mar, 2017 01:43 AM

Greetings
Today I tried to deploy a website I have been working on for some time and have been unsuccessful in reaching it while it is being hosted by appharbor. The site works fine when it is run locally, but when I attempt to access it via the appharbor web address I was given I get the following error: 403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.
The URL I am attempting to access when this error occurs is http://triviacentral.apphb.com/.
I have tried more solutions than I can count located across the forums and the internet, all to no avail.
Any help that anyone could give me would be very much appreciated

  1. 1 Posted by balexandre on 17 Mar, 2017 06:46 PM

    balexandre's Avatar

    Hi Ben,

    It seems you're able to fix the 404.

    Assuming it's a WebForms website (from the file extension) I would check the files and how are those files being registered in your solution... as you are missing the images :)

    • I'm assuming they are in a root folder called "/images", move them there if not
    • click in one image file (or select multiple images), press F4 to bring the properties up and check if the Build Action is set to Content and the Copy to Output Directory is set to either Always or Copy if newer:

    I hope it helps...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac