Is Visual Studio 2008 supported?

xtrumanx's Avatar

xtrumanx

28 Dec, 2010 09:01 AM

Well, I've got MVC2 and MVC3 RC2 apps deployed and working on appharbor. But I had an app I built on MVC2 using Visual Studio 2008 so I tried deploying it and failed. After some fruitless troubleshooting, I tried deploying a fresh MVC2 application created using Visual Studio 2008 and it failed to build.

Here's the gist of the error message:

C:\Windows\TEMP\aiepol3s.vdv\input\VS2K8MVC2Test\VS2K8MVC2Test.vbproj(173,3): error MSB4019: The imported project "C:\Program Files\MSBuild\Microsoft\VisualStudio\v9.0\WebApplications\Microsoft.WebApplication.targets" was not found. Confirm that the path in the declaration is correct, and that the file exists on disk.

I tried adding the file to my project and changing the Import declaration in my proj file but that led to a dead end (yet another failed build but this time with a less useful error message).

  1. Support Staff 1 Posted by tt on 28 Dec, 2010 12:23 PM

    tt's Avatar

    The issue with the build process have been fixed, but the application pool is being run with in .NET 4.0 mode, so your website will not be accessible after deployment. We are working to resolve this issue, and I'll get back to you as soon as we're done.

  2. Support Staff 2 Posted by tt on 28 Dec, 2010 08:43 PM

    tt's Avatar

    I have just deployed a new version of AppHarbor that will auto-detect the framework version when deploying a website. This should resolve your issue.

  3. tt closed this discussion on 28 Dec, 2010 08:43 PM.

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac