Getting 403 error site deployed using Bitbucket

silagy's Avatar

silagy

24 Jun, 2016 10:30 AM

Hi,

I have deployed a composite c1 CMS site stored on Bitbucket.
The log specified that the deployment was finished successfully.

Here is the host: http://hanisite.apphb.com/

I have looked on the following questions and answers and no one solved my problem
https://support.appharbor.com/discussions/problems/2053-403-forbidden-access-is-denied
https://support.appharbor.com/discussions/problems/21288-cant-figure-out-why-i-get-403-forbidden-access-is-denied
https://support.appharbor.com/discussions/problems/66849-aspnet-mvc-4-and-error-403-forbidden-access-is-denied

Any idea?

  1. Support Staff 1 Posted by rune on 24 Jun, 2016 02:37 PM

    rune's Avatar

    Hi,

    I tried downloading the build artifact and it looks like the issue is related to the repository structure. The application doesn't contain a solution so AppHarbor will try and deploy the application as-is.

    This assumes that the web.config file is located in the root of your repository, but it appears that your repository contains the app in a subfolder. As a result, AppHarbor will create a default web.config when processing the build which isn't compatible with the repository structure.

    The solution is to either include a solution file in your repository and let AppHarbor build and deploy that -- or alternatively, if you prefer to built it yourself, you just need to make sure that the structure is compatible with AppHarbor's build and solution file conventions (i.e. make sure the web app is at the root of the repository).

    Best,
    Rune

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac