Archived Support Site

This support site is archived. You can view the old support discussions but you cannot post new discussions.

Basic MVC app not working

spydacarnage's Avatar


04 Aug, 2015 08:40 PM


After failing to get a more complex codebase working, I've tried to upload the most basic MVC possible to work up from there.

I've created a new MVC project and uploaded the contents, and the code compiles and deploys, but when I run it, I get the below error message.

Is there something I'm missing, please?


[DirectoryNotFoundException: Could not find a part of the path 'D:\Users\apphb880807d6f15816\app\_PublishedWebsites\WebApplication1\bin\roslyn\csc.exe'.]
   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +519
   System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) +1379
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) +65
   Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.get_CompilerName() +91
   Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.FromFileBatch(CompilerParameters options, String[] fileNames) +656
   Microsoft.CodeDom.Providers.DotNetCompilerPlatform.Compiler.CompileAssemblyFromFileBatch(CompilerParameters options, String[] fileNames) +186
   System.CodeDom.Compiler.CodeDomProvider.CompileAssemblyFromFile(CompilerParameters options, String[] fileNames) +24
   System.Web.Compilation.AssemblyBuilder.Compile() +939
   System.Web.Compilation.BuildProvidersCompiler.PerformBuild() +10060089
   System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp) +9952600
   System.Web.Compilation.BuildManager.CompileGlobalAsax() +44
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +260

[HttpException (0x80004005): Could not find a part of the path 'D:\Users\apphb880807d6f15816\app\_PublishedWebsites\WebApplication1\bin\roslyn\csc.exe'.]
   System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() +62
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +435
   System.Web.Compilation.BuildManager.CallAppInitializeMethod() +33
   System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException) +545

[HttpException (0x80004005): Could not find a part of the path 'D:\Users\apphb880807d6f15816\app\_PublishedWebsites\WebApplication1\bin\roslyn\csc.exe'.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9920760
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +101
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +261

  1. Support Staff 1 Posted by rune on 05 Aug, 2015 10:27 PM

    rune's Avatar

    Hi Mark,

    Yep this is a common problem and better support for the new VS2015 templates is in the works, but it's easy to fix this with a simple build target in a post-build event. Take a look at my answer in this discussion for more information and a sample MVC5 app using Roslyn.


  2. 2 Posted by spydacarnage on 06 Aug, 2015 09:04 AM

    spydacarnage's Avatar

    Thanks, Rune.

    I had played around with stuff a little bit along the same lines and managed to get it working. :-)


  3. Support Staff 3 Posted by rune on 06 Aug, 2015 12:17 PM

    rune's Avatar

    Thanks for the heads up, glad you figured it out! :-)


  4. rune closed this discussion on 06 Aug, 2015 12:17 PM.

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac