Web.config customErrors setting? (Again)
Hi all. I have the same problem as another guy on here - my web.config setting for customerrors is not working. It works fine on my local machine. I don't understand what Rune Sørensen meant by "The Web.Config referenced in TellBob isn't copied to the web servers becasuse it is set as an embedded resource. " Can anyone shed any light? Thanks!
My actual problem is db related, I think. But I can't see the error to debug.
Original Discussion link:
http://support.appharbor.com/discussions/problems/100-customerrors-...
Discussions are closed to public comments.
If you need help with AppHarbor please
start a new discussion.
Keyboard shortcuts
Generic
| ? | Show this help |
|---|---|
| ESC | Blurs the current field |
Comment Form
| r | Focus the comment reply box |
|---|---|
| ^ + ↩ | Submit the comment |
You can use Command ⌘ instead of Control ^ on Mac
Support Staff 1 Posted by rune on 17 Mar, 2011 08:55 AM
Hi Sharon,
I was referring to the "Build Action" property for the file - you can see whether your property is set to "Content" as it should be, by right-clicking the web.config file in Visual Studio and selecting "Properties".
Not sure that's the issue in this case though - let me know if it doesn't help you.
Thanks,
Rune
rune closed this discussion on 17 Mar, 2011 08:55 AM.
sharon.talbot re-opened this discussion on 17 Mar, 2011 05:04 PM
2 Posted by sharon.talbot on 17 Mar, 2011 05:04 PM
Yes, it is set to "Content".
Any other suggestions? Please keep in mind that I can see errors on my local box just fine. Thanks!
Support Staff 3 Posted by friism on 17 Mar, 2011 06:55 PM
Can you invite [email blocked] as a collaborator, then I can take a look at your app.
4 Posted by sharon.talbot on 17 Mar, 2011 07:54 PM
Done. Please note - the page I'm expecting to work is the "Readings" page. The login page is not really implemented yet.
Support Staff 5 Posted by friism on 18 Mar, 2011 06:51 AM
So your your application is http://tellbob.apphb.com/ correct? If I hit that url, I get a Yellow-Screen-of-Death (not a custom error page) showing a Telerik.OpenAccess error. That would mean that you have succeeded in setting
customErrorstofalse.Let me know if this doesn't resolve your query.
friism closed this discussion on 18 Mar, 2011 06:51 AM.
sharon.talbot re-opened this discussion on 18 Mar, 2011 06:53 AM
6 Posted by sharon.talbot on 18 Mar, 2011 06:53 AM
No, my app is GeigerCrowd...I don't know the other person, but he apparently had a similar problem that is now resolved.
Support Staff 7 Posted by friism on 18 Mar, 2011 07:37 AM
Your web.config transformations are somehow incorrectly specified. It works if the customerrors element is placed in the main web.config: http://geigercrowd.apphb.com/ReadingPoints
Maybe it did not work originally because the customerrors was not placed in the master web.config and the
Replacetransform requires the element be there to start with.friism closed this discussion on 18 Mar, 2011 07:37 AM.