Build was successful and the deploy but the site serves a 403 error
This comment was split from the discussion: Build was successful and the deploy but the site serves a 403 error
This is also happening to me on http://bitbuckettest-1.apphb.com/ with a simple page that just has Default.aspx. Successful build, but HTTP403.
Repository is:
https://***@bitbucket.org/turanuk/bitbuckettest
Discussions are closed to public comments.
If you need help with AppHarbor please
start a new discussion.
Keyboard shortcuts
Generic
| ? | Show this help |
|---|---|
| ESC | Blurs the current field |
Comment Form
| r | Focus the comment reply box |
|---|---|
| ^ + ↩ | Submit the comment |
You can use Command ⌘ instead of Control ^ on Mac
Support Staff 1 Posted by friism on 10 Mar, 2011 07:10 PM
Are you pushing a full solution/project repository? We generally need that to properly build and deploy your code (although there are exceptions for WebMatrix projects).
Let me know if this doesn't resolve your problem.
friism closed this discussion on 10 Mar, 2011 07:10 PM.
Jim Wang (WPT) re-opened this discussion on 10 Mar, 2011 08:58 PM
2 Posted by Jim Wang (WPT) on 10 Mar, 2011 08:58 PM
Do you guys have WebMatrix in your GAC? I was bin deploying it initially and that was still returning the 403.
Cheers,
Jim Wang
We are hiring!
-----Original Message-----
From: Michael Friis [mailto:[email blocked]]
Sent: Thursday, March 10, 2011 11:11 AM
To: Jim Wang (WPT)
Subject: Re: Build was successful and the deploy but the site serves a 403 error [Support]
3 Posted by Jim Wang on 10 Mar, 2011 10:24 PM
I guess a more general question would be how I deploy a site with just plain .html files, this seems to also return a 403, and a 404 for the actual html files...i.e. in the case that all my repository has is index.html.
Support Staff 4 Posted by friism on 10 Mar, 2011 11:00 PM
Your safest bet would be to create a Visual Studio web project with a static html file that you make sure has
Build actionset toContentin its properties. Those files will be copied to the output directory and deployed.I'm investigating the WebMatrix situation.
Support Staff 5 Posted by tt on 10 Mar, 2011 11:10 PM
For WebMatrix sites, we inject a configuration file if it doesn't exist in the repository. If it do exist, you need to configure it with the sections below manually:
In case you are deploying plain HTML content, you just need to add that to the
defaultDocumentsection.tt closed this discussion on 10 Mar, 2011 11:10 PM.
Jim Wang (WPT) re-opened this discussion on 10 Mar, 2011 11:18 PM
6 Posted by Jim Wang (WPT) on 10 Mar, 2011 11:18 PM
Thanks Troels, unfortunately this still returns a 403 both with and without the WebMatrix assemblies in the bin directory.
Cheers,
Jim Wang
We are hiring!
-----Original Message-----
From: Troels [mailto:[email blocked]]
Sent: Thursday, March 10, 2011 3:10 PM
To: Jim Wang (WPT)
Subject: Re: Build was successful and the deploy but the site serves a 403 error [Support]
Support Staff 7 Posted by tt on 11 Mar, 2011 02:01 AM
Sorry, Jim. I should have looked more into it before, but the configuration file usually resolves the issue.
The tarball we receive from Bitbucket contains a root directory with the same name as the tarball itself. This isn't an issue when we look for a solution file, but it turned out to be for the WebMatrix bits.
We have fixed this issue, so if you make a change and push again, everything should work out.
tt closed this discussion on 11 Mar, 2011 02:01 AM.