Remote SQL Login with SQL Studio Manager
No matter how much I fiddle with the connection settings, I
cannot establish a connection to the remote sql server:
I've turned off firewall settings, and played with port numbers.
Error message below:
Error message:
Cannot connect to db000.appharbor.net,1433.
ADDITIONAL INFORMATION:
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060)
Discussions are closed to public comments.
If you need help with AppHarbor please
start a new discussion.
Keyboard shortcuts
Generic
| ? | Show this help |
|---|---|
| ESC | Blurs the current field |
Comment Form
| r | Focus the comment reply box |
|---|---|
| ^ + ↩ | Submit the comment |
You can use Command ⌘ instead of Control ^ on Mac
Support Staff 1 Posted by friism on 24 Feb, 2011 09:29 PM
db000 is definately up on our end and accepting connections. You're not sitting in Starbucks by any chance (or on a similar network that may block ports other than 80)?
2 Posted by Chris Parnin on 24 Feb, 2011 09:32 PM
Connected through Georgia Tech's wireless. Don't believe they block 1433.
3 Posted by Chris Parnin on 24 Feb, 2011 09:51 PM
http://www.lawn.gatech.edu/security/index.html
1433 - is BLOCKED.
Is there a way to an easy way around this on my end?
Support Staff 4 Posted by friism on 24 Feb, 2011 10:00 PM
Not really... It seems your network is not blocking Remote Desktop connections, so you could potentially remote desktop to some other Windows machine outside the firewall and run SQL Server Management Studio there. If you don't have one available, you could fire up an EC2 micro instance. It's all rather involved though.
5 Posted by danesparza on 25 Feb, 2011 07:01 PM
If you're familiar with Linux and SSH, you could setup a free Linux EC2 instance on Amazon, and port forward with the SSH daemon. That one is definitely involved (and not for the faint of heart!) but I've used similar solutions in the past to great effect.
Support Staff 6 Posted by friism on 26 Feb, 2011 08:11 PM
Also a good suggestion, thanks Dan,
friism closed this discussion on 26 Feb, 2011 08:11 PM.