Problem MS SQL nano plan

350540's Avatar

350540

02 Aug, 2019 06:55 PM

I cannot connect to my MS SQL sql database neither from my app, neither Sql Server Management studio, and sqlpackage.exe

Error is:

*** Error exporting database:Could not extract package from specified database. There is insufficient system memory in resource pool 'internal' to run this query.

SSMS error:

Error connecting to '1d7b03e7-8754-47e2-8772-a8a90132656c.sqlserver.sequelizer.com'.
ADDITIONAL INFORMATION:

Error: 3980, Severity: 16, State: 1. (Params:). The error is printed in terse mode because there was error during formatting. Tracing, ETW, notifications etc are skipped.
(Microsoft SQL Server, Error: 3980)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&am...

Yesterday everything worked fine, nothing changed. Database is not over limit (17/20 Mb). I even swtich off my app (change connection string), no payload on SQL - but error still the same.

Looks like an infrastructure issue.

Db Server: 1d7b03e7-8754-47e2-8772-a8a90132656c.sqlserver.sequelizer.com
Database: db1d7b03e7875447e28772a8a90132656c

  1. Support Staff 1 Posted by rune on 02 Aug, 2019 10:15 PM

    rune's Avatar

    Hi,

    Yes there was unfortunately an issue affecting the server hosting your database -- the problem was resolved just a few minutes again and it should be back to normal now.

    That being said, the shared SQL server databases are intended only for development and staging purposes, and I'd highly recommend you move to a dedicated option for higher availability and more consistent performance.

    AWS provides quite cost-effective dedicated SQL server instances through their managed RDS service, which also happens to integrate easily with AppHarbor. Let me know if you need help setting that up, or there's anything else I can help with!

    Best,
    Rune

  2. rune closed this discussion on 02 Aug, 2019 10:15 PM.

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac