500 Internal Server AppHarbor - Bitbucket bridge

DGibson8822's Avatar

DGibson8822

28 Jul, 2019 01:18 AM

After creating my first AppHarbor application, I attempt to use the "Configure Bitbucket to deploy to AppHarbor" link provided in the getting started section. The next page prompts me to grant permission to AppHarbor. Doing so results in a 500 internal server error page from AppHarbor. Reloading the app page and checking the repository url, I see that it still show's AppHarbor's repository and not Bitbucket's.

I've tried refreshing the pages, logging out and back into everything, restarting my browser, and restarting my computer. I searched the discussions for the same issue, and only found 2 similar ones, except for one of them the user was trying to bridge to Github instead of Bitbucket. In both cases, it seems like something had to be adjusted on AppHarbor's end. Links to both of those posts:

https://support.appharbor.com/discussions/problems/80007-bitbucket-integration-seems-to-be-failing

https://support.appharbor.com/discussions/problems/94643-500-error-when-making-a-bridge-to-github

Any help would be greatly appreciated. I'm pretty new to all of this, so please forgive me if I've missed something obvious.

EDIT: After posting this I also noticed that, in my Bitbucket oauth settings, AppHarbor seems to be correctly listed as authorized.

  1. Support Staff 1 Posted by rune on 19 Aug, 2019 06:02 AM

    rune's Avatar

    Hi,

    Apologies for the slow response on this issue -- you're right, there's currently an issue affecting the Bitbucket integration setup for new repositories (although not related to the two discussions you linked to, so thanks for reporting this).

    We're working to resolve this as soon as possible, but in the the meantime, have you tried pushing to AppHarbor directly using the built-in Git repository?

    Best,
    Rune

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac