6/14/19 10:12 AM Downloading source failed: An error occurred while downloading the source

Milleson's Avatar

Milleson

14 Jun, 2019 11:16 PM

ContactWeb
Branch name: master

Commit ID: 334aec2b3d55908e6e40e181463b7cedb73def6b

Commit message: push7

Log Time Message
6/14/19 10:12 AM Received notification, queuing build
6/14/19 10:12 AM Downloading source
6/14/19 10:12 AM Downloading source failed: An error occurred while downloading the source

Getting this message every time I push from git gui through: https://[email blocked]/milleson2/contactweb.git
to AppHarbor.

I'VE TRIED THE FOLLOWING 3 FIXES AND THESE PUSHES HAVE ALL FAILED. I even tried the fix where I put a Roslyn folder into the Bin folder and inside that, put: csc.exe

<PropertyGroup>
   <PostBuildEvent>
   if not exist "$(WebProjectOutputDir)\bin\Roslyn" md "$(WebProjectOutputDir)\bin\Roslyn"
   start /MIN xcopy /s /y /R "$(OutDir)roslyn\*.*" "$(WebProjectOutputDir)\bin\Roslyn"
 </PostBuildEvent>
</PropertyGroup>

<Target Name="DeleteDuplicateAnalysisFiles" AfterTargets="AfterBuild">
   <!-- Jenkins now has copies of the following files in both the bin directory and the 'bin\rosyln' directory. Delete from bin. -->
   <ItemGroup>
     <FilesToDelete Include="$(WebProjectOutputDir)\bin\Microsoft.CodeAnalysis*.dll" />
   </ItemGroup>
   <Delete Files="@(FilesToDelete)" />
</Target>

<Target Name="CopyRoslynFiles" AfterTargets="AfterBuild" Condition="!$(Disable_CopyWebApplication) And '$(OutDir)' != '$(OutputPath)'">
    <ItemGroup>
      <RoslynFiles Include="$(CscToolPath)\*" />
    </ItemGroup>
    <MakeDir Directories="$(WebProjectOutputDir)\bin\roslyn" />
    <Copy SourceFiles="@(RoslynFiles)" DestinationFolder="$(WebProjectOutputDir)\bin\roslyn" SkipUnchangedFiles="true" Retries="$(CopyRetryCount)" RetryDelayMilliseconds="$(CopyRetryDelayMilliseconds)" />
</Target>

<Target Name="CopyRoslynCompilerFilesToPublishedWebsitesDirectory" AfterTargets="AfterBuild" Condition="Exists('$(OutDir)\_PublishedWebsites\$(TargetName)')">
    <Copy SourceFiles="@(RoslyCompilerFiles)" DestinationFolder="$(OutDir)\_PublishedWebsites\$(TargetName)\bin\roslyn" ContinueOnError="true" SkipUnchangedFiles="true" />
</Target>

STATUS RECEIVED DEPLOYED COMMIT ID COMMIT MESSAGE
Failed 6/14/19 10:12 AM 334aec2b3d55908e6e40e181463b7cedb73def6b push7
Failed 6/14/19 9:50 AM 3a21aedfe682fc9b4edfc89a504f4a725a392423 push6
Failed 6/14/19 9:33 AM e0cbe2a914801e0dbb693e16e456b95e6040c399 push6
Failed 6/14/19 9:26 AM 67f80341b3d631519f8a6cd32b346381bec10932 push5
Failed 6/14/19 9:24 AM 872effd06ea3add9e47089af221520cdd1b63f88 push4
Failed 6/14/19 9:19 AM 7eae00dfe715ac3653fc21ca45795792db434688 push3
Failed 6/14/19 9:18 AM 18e7dfb004de92ef6b0e6ff8b948e6ac9575041c push2
Failed 6/14/19 9:16 AM 07cb320d43eee226fa1501a20aac6db9ba579090 Push1

Thanks for any help. I've deleted and remade ContactWeb twice and have simplified the upload to not include the Packages folder. This is the latest MVC DotNet arrangement from Visual Studio:

Microsoft Visual Studio Community 2017 Version 15.9.8
VisualStudio.15.Release/15.9.8+28307.481
Microsoft .NET Framework Version 4.7.03056

Installed Version: Community

Add New File 3.5.134
ASP.NET and Web Tools 2017 15.9.04012.0
ASP.NET Core Razor Language Services 15.8.31590
ASP.NET Web Frameworks and Tools 2017 5.2.60913.0
Azure App Service Tools v3.0.0 15.9.03024.0
Azure Functions and Web Jobs Tools 15.9.02046.0
Bundler & Minifier 2.8.396
C# Tools 2.10.0-beta2-63501-03+b9fb1610c87cccc8ceb74a770dba261a58e39c4a
Common Azure Tools 1.10
CSS Tools 1.1.23
EditorConfig Language Service 1.17.260
File Icons 2.7
File Nesting 2.6.85
HTML Tools 1.0.3
Image Optimizer 4.0.132
Image Sprites 1.4.58
JavaScript Language Service 2.0
JetBrains ReSharper Ultimate 2018.3.3 Build 183.0.20190208.91313
Markdown Editor 1.12.236
Microsoft Azure Tools for Microsoft Visual Studio 2017 - v2.9.0.0
Microsoft Continuous Delivery Tools for Visual Studio 0.4
Microsoft JVM Debugger 1.0
Microsoft Library Manager 1.0
Microsoft MI-Based Debugger 1.0
Microsoft Visual Studio Tools for Containers 1.1
NuGet Package Manager 4.6.0
Open Command Line 2.1.218
Package Installer 2.0.103
Package Security Alerts 1.0.22
Project File Tools 1.0.1
ProjectServicesPackage Extension 1.0
ResourcePackage Extension 1.0
SQL Server Data Tools 15.1.61902.21100
TypeScript Tools 15.9.20918.2001
Visual Basic Tools 2.10.0-beta2-63501-03+b9fb1610c87cccc8ceb74a770dba261a58e39c4a
Visual F# Tools 10.2 for F# 4.5 15.8.0.0. Commit Hash: 6e26c5bacc8c4201e962f5bdde0a177f82f88691.
Visual Studio Code Debug Adapter Host Package 1.0
Visual Studio Tools for Containers 1.0
Web Accessibility Checker 1.5.58
Web Compiler 1.12.394 Compiler for LESS, Sass and CoffeeScript files
Web Essentials 2017 2.0.44

Thanks Again !

Paul Milleson

  1. 1 Posted by Milleson on 17 Jun, 2019 10:42 PM

    Milleson's Avatar

    I removed the Bin folder before the push and i finally got a log file and some relevant error messages. (like: can't find the compiler) as called out in WebConfig and in Global.asax.cs, so I put a pretend change into Global.asax.cs and returned to Bin folder to its rightful place and pushed all that back up through bitbucket and all is well now.

    It was very frustrating getting unhelpful error messages that simply said:

    Downloading source failed: An error occurred while downloading the source

    and the log link wasn't being provided so who knows what in the download source appHarbor had actually choked on, or if it was really a permission issue and the download hadn't even started - it was impossible to troubleshoot with the information given... surely there's a way to monitor the individual files as they come down, until the stream breaks, or to pick up an actual complaint from the handling code about why the download is being aborted....

  2. Milleson closed this discussion on 17 Jun, 2019 10:42 PM.

  3. Milleson re-opened this discussion on 17 Jun, 2019 10:43 PM

Discussions are closed to public comments.
If you need help with AppHarbor please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac