502 Bad Gateway nginx/0.8.54

gsohal's Avatar

gsohal

03 Apr, 2011 07:45 PM

I have just deployed my site :http://bloggurpreetsohalcom.apphb.com/

Build successful and I even put in a index.htm file, but it just keeps on showing the same error 502 Bad Gateway nginx/0.8.54

  1. 2 Posted by gsohal on 03 Apr, 2011 07:55 PM

    gsohal's Avatar

    Ok now I'm seeing :

    Service Unavailable

    HTTP Error 503. The service is unavailable.

  2. Support Staff 3 Posted by friism on 03 Apr, 2011 08:20 PM

    friism's Avatar

    Are you trying to deploy Orchard by any chance? It's pretty tempremental, here are some suggested posts:
    http://support.appharbor.com/discussions/problems/203-orchard-support
    http://support.appharbor.com/discussions/problems/153-deploying-and...

  3. friism closed this discussion on 03 Apr, 2011 08:20 PM.

  4. gsohal re-opened this discussion on 03 Apr, 2011 08:35 PM

  5. 4 Posted by gsohal on 03 Apr, 2011 08:35 PM

    gsohal's Avatar

    I am trying to deploy orchard. However I have not run into the issue mentioned in the first discussion.

    The second discussion is private

    ------Original Message------
    From: Michael Friis
    To: [email blocked]
    ReplyTo: [email blocked]
    Subject: Re: 502 Bad Gateway nginx/0.8.54 [Support]
    Sent: 3 Apr 2011 21:20

  6. Support Staff 5 Posted by friism on 03 Apr, 2011 09:15 PM

    friism's Avatar

    Does it work when you run locally? If so, please invite [email blocked] so that we can take a look.

  7. 6 Posted by gsohal on 03 Apr, 2011 11:45 PM

    gsohal's Avatar

    How do I invite you to see it working locally?

    Gurpreet

    On Sun, Apr 3, 2011 at 10:15 PM, Michael Friis <
    [email blocked]> wrote:

  8. 7 Posted by gsohal on 03 Apr, 2011 11:48 PM

    gsohal's Avatar

    is there anyway for me to see the compiled files?

  9. Support Staff 8 Posted by friism on 04 Apr, 2011 12:19 AM

    friism's Avatar

    So I'm curious to know whether the contents of the repository you are pushing to AppHarbor works when you run it locally, i.e. either in the development web server or on you local IIS?

    You cannot get the build output, but it is something we might add.

  10. 9 Posted by gsohal on 04 Apr, 2011 07:01 AM

    gsohal's Avatar

    It does indeed work locally.
    Sent from my BlackBerry® wireless device

    -----Original Message-----
    From: "Michael Friis" <[email blocked]>
    Date: Sun, 03 Apr 2011 20:19:49
    To: [email blocked]<[email blocked]>
    Reply-To: [email blocked]
    Subject: Re: 502 Bad Gateway nginx/0.8.54 [Support]

  11. Support Staff 10 Posted by friism on 04 Apr, 2011 07:12 AM

    friism's Avatar

    Could you invite [email blocked] as a collaborator, then we can take a look?

  12. Support Staff 11 Posted by rune on 04 Apr, 2011 07:30 AM

    rune's Avatar

    Hi,

    It seems like some unhandled exceptions are thrown during application start up. These causes the application pool to crash (most likely because they happen in a thread outside the request context) and the 502 is displayed because the website isn't responding to the request from the load balancer.

    Here's the stack trace:

    An unhandled exception occurred and the process was terminated.

    Application ID: /LM/W3SVC/276/ROOT

    Process ID: 11532

    Exception: System.NullReferenceException

    Message: Object reference not set to an instance of an object.

    StackTrace: at Orchard.Startup.WarmupHttpModule.Signal() in C:\code\gurpreetsohal.com\Orchard.Startup\WarmupHttpModule.cs:line 33
    at Orchard.Startup.Starter.<>cDisplayClass1.b0(Object state) in C:\code\gurpreetsohal.com\Orchard.Startup\Starter.cs:line 60 at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

  13. 12 Posted by gsohal on 04 Apr, 2011 09:09 AM

    gsohal's Avatar

    I don't get this error on my local machine at all, hosted in IIS or casini.
    How can I debug this, if I can't reproduce the error

    On Mon, Apr 4, 2011 at 8:30 AM, Rune Sørensen <
    [email blocked]> wrote:

  14. Support Staff 13 Posted by rune on 04 Apr, 2011 02:02 PM

    rune's Avatar

    I think the problem may be related to the fact that only your App_Data folder is writable.. Orchard requires that other folders are writable under certain conditions. If you want to reproduce the issue locally you can try and make sure that the user account under which the web site runs (set it up under your application pool) only has read access to all folders except the App_Data folder.

    You can also try and bin-deploy the modules which may be the cause of this issue. You can read more about it here: http://www.orchardproject.net/docs/Default.aspx?Page=Orchard-module... - you should be able to use the "Referenced Module" and "Precompiled Module" for loading modules.

    We are aware that there are certain kinks to running various CMS' and will work on improving support for these. If you figure it out and get it up and running we would love to hear more about it!

    Best,
    Rune

  15. rune closed this discussion on 04 Apr, 2011 02:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac